logic pro X文档

钢琴卷帘编辑器概述

MIDI 片段中的音符在钢琴卷帘编辑器中显示为时间网格中的彩条。水平线显示时间位置,垂直线表示音高。钢琴卷帘编辑器左边缘的键盘提供有关音符音高的引用。钢琴卷帘编辑器菜单栏中的信息显示展示指针下方的音符名称和时间位置。

您可以将键盘切换到自适应视图,它会基于 MIDI 所选片段自动选择最佳钢琴卷帘显示。在这种情况下,所有显示的 MIDI 片段由提供音符名称的乐器播放,键盘由显示这些音符名称的表格取代。您还可以切换到折叠模式视图,只有所选 MIDI 片段内音符使用的主道会显示在钢琴卷帘编辑器中。

钢琴卷帘编辑器可以显示文件夹中单个轨道或项目中多个轨道上的 MIDI 片段。请参阅在钢琴卷帘编辑器中查看多个 MIDI 片段

图。钢琴卷帘编辑器,指出 MIDI 音符事件。

您可以将钢琴卷帘编辑器作为主窗口中的面板打开,也可以将其作为独立、可调整大小的窗口打开。

打开钢琴卷帘编辑器

请执行以下一项操作:

  • 选择软件乐器(或外部 MIDI 乐器)轨道或 MIDI 片段,然后点按“编辑器”按钮
  • 选择软件乐器(或外部 MIDI 乐器)轨道或 MIDI 片段,然后选取“显示”>“显示编辑器”。
  • 连按 MIDI 片段(如果从“Logic Pro”>“偏好设置”>“通用”>“编辑”>“连按 MIDI 片段会打开”弹出式菜单中选取钢琴卷帘)。钢琴卷帘编辑器在轨道区域下方打开。左侧的控制用于量化 MIDI 片段的时序和音高、调整其音高以及编辑 MIDI 音符的力度。钢琴卷帘编辑器的顶部是显示时间等份的标尺,带有窗内菜单的菜单栏,工具及其他控制。标题显示所选片段的名称(或片段的数量,如果已选定多个片段)。

将钢琴卷帘编辑器切换到自适应视图

  • 在钢琴卷帘编辑器菜单栏中选取“显示”>“鼓名称”。

将钢琴卷帘编辑器切换到折叠模式视图

  • 点按钢琴卷帘编辑器菜单栏中的“折叠模式”按钮。
    图。钢琴卷帘编辑器,指示了“折叠模式”按钮。

将钢琴卷帘编辑器作为单独的窗口打开

请执行以下一项操作:

  • 选取“窗口”>“打开钢琴卷帘”(或按下 Command-4)。
  • 拖移钢琴卷帘编辑器的标题以将其拖出主窗口。

垂直调整钢琴卷帘编辑器的大小

  • 将指针置于编辑器顶部的栏中,然后向上拖移。再向下拖移使编辑器变小。

隐藏或显示窗内钢琴卷帘编辑器检查器

  • 若要隐藏钢琴卷帘编辑器检查器:请从钢琴卷帘编辑器的“视图”菜单中选取“隐藏窗内检查器”。
  • 若要显示钢琴卷帘编辑器检查器:请从钢琴卷帘编辑器的“视图”菜单中选取“显示窗内检查器”。

设定钢琴卷帘编辑器的链接模式

您可以打开钢琴卷帘编辑器的“内容”链接,以便它始终显示当前所选 MIDI 片段的内容。“相同级别”链接不可用于钢琴卷帘编辑器。

  • 若要将链接模式设定为“内容”:点按钢琴卷帘编辑器菜单栏中的链接按钮。
  • 若要将链接模式设定为“关”:再次点按钢琴卷帘编辑器菜单栏中的链接按钮。

有关使用“链接”模式的更多信息,请参阅使用“链接”模式控制窗口关系

更改钢琴卷帘编辑器的背景

默认情况下,钢琴卷帘编辑器将音符显示在黑色背景上。如果您喜欢颜色较浅的背景,可以在“显示”偏好设置中更改背景。

  1. 选取“Logic Pro X”>“偏好设置”>“显示”。
  2. 点按“编辑器”,然后选择“钢琴卷帘”:“明亮背景”复选框。

关闭钢琴卷帘编辑器

  • 点按“编辑器”按钮
分享到
×用微信扫描并分享

国内最专业的影视人社区

来自国际最前沿的技术, 分享一线实战经验

null

长按二维码,关注NewVFX文档